Range Product

题目描述

You are given two integers a and b (a≤b). Determine if the product of the integers a, a+1, …, b is positive, negative or zero.

Constraints
a and b are integers.
−109≤a≤b≤109
Partial Score
In test cases worth 100 points, −10≤a≤b≤10.

输入

The input is given from Standard Input in the following format:
a b

输出

If the product is positive, print Positive. If it is negative, print Negative. If it is zero, print Zero.

样例输入

1 3

样例输出

Positive

提示

1×2×3=6 is positive.

      不知道该这么说,也是一道简单题。。。就对a,b进行判断,如果a<=0&&b>=0,从a到b的数乘积一定为0,直接输出Zero;否则就判断a<=0,并用b减去a,判断能否被2整除,能则输出Positive,不能则输出Negative;再否则就直接输出Positive。

以下贴上代码:

#include<cstdio>
#include<iostream>
using namespace std;
 
int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        if(a<=0&&b>=0)
            cout<<"Zero"<<endl;
        else if(a<0)
        {
            int key=b-a;
            if(key%2!=0)
                cout<<"Positive"<<endl;
            else
                cout<<"Negative"<<endl;
        }
        else
            cout<<"Positive"<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值