HRBUST 1012 Catch That Cow

Catch That Cow
Time Limit: 2000 MSMemory Limit: 65536 K
Total Submit: 2610(692 users)Total Accepted: 1010(624 users)Rating: Special Judge: No
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

For each test case :

Line 1: Two space-separated integers: N and K

Process to the end of file.

Output

For each test case :

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17
100 100
Sample Output
4
0

这个题是一个基础的bfs搜索题罢了,没有任何好讲的,就把所有可能走到的点全部放入queue容器中,不断的进行查找而已。以下是代码:

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;

const int maxn=1e5+5;
queue<int>p;
int step[maxn];
bool vis[maxn];


int main(){
    int a,b;
    while(cin>>a>>b){
        while(!p.empty()){
            p.pop();
        }
        memset(step,0,sizeof(step));
        memset(vis,0,sizeof(vis));
        p.push(a);
        vis[a]=1;
        while(!p.empty()){
            int key=p.front();
            p.pop();
            if(key+1<=100000&&!vis[key+1]){
                p.push(key+1);
                vis[key+1]=1;
                step[key+1]=step[key]+1;
            }
            if(key-1>=0&&!vis[key-1]){
                p.push(key-1);
                vis[key-1]=1;
                step[key-1]=step[key]+1;
            }
            if(key*2<=100000&&!vis[key*2]){
                p.push(key*2);
                vis[key*2]=1;
                step[key*2]=step[key]+1;
            }
            if(key==b){
                break;
            }
        }
        cout<<step[b]<<endl;
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值