HRBUST 1004 The Triangle

The Triangle
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 1944(903 users)Total Accepted: 1077(834 users)Rating: Special Judge: No
Description
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 
 
Input

Your program is to read from standard input.

For each test case, the first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Process to the end of file.

Output

For each test case, your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

这个题目是动态规划里面最简单的一类题目了,就是一个很典型数塔问题,我们从数塔的最下方向上方不断进行加法运算就好了,状态转移方程是dp[i-1][j]+=max(dp[i][j],dp[i][j+1]);好了,以下贴上代码:

#include<iostream>
#include<cstdio>
using namespace std;

const int MAXN=1005;
int dp[MAXN][MAXN];

int main(){
    int n;
    while(cin>>n){
        int i,j;
        for(int i=0;i<n;i++){
            for(int j=0;j<=i;j++){
                cin>>dp[i][j];
            }
        }
        for(int i=n-1;i>=1;i--){
            for(int j=0;j<i;j++){
                dp[i-1][j]+=max(dp[i][j],dp[i][j+1]);
            }
        }
        cout<<dp[0][0]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值