心得:
1.遍历查找很慢,时间是O(n),而直接索引查找非常快,时间是O(1),所以当需要速度时,就用索引找,最典型的就是map容器,每创建一个新变量,就将其存在map中,用1表示它存在,这样在查看某项是否存在时就调用m[some]查看只是不是1
2.当某一项可以用int表示时,就用int,因为int的存取比string字符串快很多
题目:
“单身狗”是中文对于单身人士的一种爱称。本题请你从上万人的大型派对中找出落单的客人,以便给予特殊关爱。
输入格式:
输入第一行给出一个正整数 N(≤ 50 000),是已知夫妻/伴侣的对数;随后 N 行,每行给出一对夫妻/伴侣——为方便起见,每人对应一个 ID 号,为 5 位数字(从 00000 到 99999),ID 间以空格分隔;之后给出一个正整数 M(≤ 10 000),为参加派对的总人数;随后一行给出这 M 位客人的 ID,以空格分隔。题目保证无人重婚或脚踩两条船。
输出格式:
首先第一行输出落单客人的总人数;随后第二行按 ID 递增顺序列出落单的客人。ID 间用 1 个空格分隔,行的首尾不得有多余空格。
输入样例:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
输出样例:
5
10000 23333 44444 55555 88888
思路:
用map存储情侣或者夫妻,键作为本人,值作为其爱人,所以一对情侣要存两次;
用一个map<int,bool>容器来存这个人是否有爱人,这样在判断的是否,如果发现其没有爱人,就将其存进结果数组
如果有爱人,还要查看其爱人来没来,没来也要存进结果数组
代码:
#include<iostream>
#include<map>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
int num,query_num,temp,temp1,temp2;
vector<int> res;
map<int,int> m;
map<int,bool> is_come;
map<int,bool> no_single;
cin>>num;
for(int i=0;i<num;i++)
{
scanf("%d %d",&temp1,&temp2);
m[temp1]=temp2;
m[temp2]=temp1;
no_single[temp1]=true;
no_single[temp2]=true;
}
cin>>query_num;
for(int i=0;i<query_num;i++)
{
scanf("%d",&temp);
if(!no_single[temp])
res.push_back(temp);
else
is_come[temp]=true;
}
for(auto it=is_come.begin();it!=is_come.end();it++)
{
if(!is_come[m[it->first]])
res.push_back(it->first);
}
sort(res.begin(),res.end());
printf("%d\n",res.size());
for(int i=0;i<res.size();i++)
{
printf("%05d",res.at(i));
if(i!=res.size()-1)
printf(" ");
else
printf("\n");
}
return 0;
}