POJ3080-Blue Jeans

 

题目链接:点击打开链接

 

 

Blue Jeans

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20430 Accepted: 9053

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

题目大意:找3个所给字符串的最长公共子序列,(长度大于等于3)

思路:拿第一个字符串,暴力取字串,长度递增,去其他字符串里面找。

AC代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<vector> 
#include<algorithm>
using namespace std;

string str[15];
string temp;
vector<string> t;
vector<string> ans;

bool cmp(string a, string b) {//优先顺序
	if(a.size() == b.size())
		return a < b;
	else
		return a.size() > b.size();
}

 

int main() {
	int n, m;
	while(cin >> n) {
		while(n--) {
			cin >> m;
			for(int i = 0; i < m; i++) {//存储
				cin >> str[i];
			}
			ans.clear();
			for(int j = 3; j <= 60; j++) {//最短3,最长60
				for(int i = 0; i <= str[0].size() - j; i++) {//注意等号
					int flag = 0;
					temp = str[0].substr(i, j);//从i开始,取长度为j的字串
					for(int k = 1; k < m; k++) {//去其他字符串里面找
						if(str[k].find(temp) == string::npos) {
							flag = 1;
							break;
						}
					}
					if(flag == 0)
						ans.push_back(temp);//合法的
				}
			}
			sort(ans.begin(), ans.end(), cmp);//第一个就是
			if(ans.size() != 0)
				if(ans[0].size() >= 3)
					cout << ans[0] << endl;
				else
					cout << "no significant commonalities" << endl;
			else
				cout << "no significant commonalities" << endl;
		}
	}
}

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值