POJ1936-All in All

题目链接:点击打开链接

 

All in All

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 35348 Accepted: 14736

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

题目大意:和第一题一样,在长的里面找短的所有字符。

思路:刚开始没有这样写,用的find,然后比较下标,但是由于find是第一个找到的下标,出现重复字母就错了,后来就用第一种了。

AC代码:

 

#include<iostream>

#include<string>
#include<cstdio>
using namespace std;

string s, t;
int main() {
	while(cin >> s) {
		cin >> t;

		int j = 0, i;
		for(i = 0; i < s.size(); ) {//跑一遍,找到字符就往后,找不到就不动
			if(j == t.size())
				break;
			if(t[j] == s[i]) {
				j++;
				i++;
			} else {
				j++;
			}
		}
		if(i == s.size())//判断是否能跑完
			printf("Yes\n");
		else
			printf("No\n");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值