POJ1936-All in All(纯水题)

POJ1936 原题链接:http://poj.org/problem?id=1936

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33646 Accepted: 14057

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source


题目大意:在s2中是否能找到s1中的所有字母;
 
思路:没什么思路模拟就行;


代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int main()
{
    char s1[100001];
    char s2[100001];
    long len1;
    long len2;
    while(cin>>s1>>s2)
    {
        int i,j;
        i=0;           //i为s1的标识,j为s2的标识
        j=0;
        len1=strlen(s1);
        len2=strlen(s2);
        while(true)
        {
            if(i==len1)
            {
                cout<<"Yes"<<endl;
                break;
            }
            else if(i<len1&&j==len2)
            {
                cout<<"No"<<endl;
                break;
            }
            if(s1[i]==s2[j])
            {
                i++;
                j++;
            }
            else j++;
        }
        memset(s1,'\0',sizeof(s1));
        memset(s2,'\0',sizeof(s2));
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值