食物链

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 
有人用两种说法对这N个动物所构成的食物链关系进行描述: 
第一种说法是"1 X Y",表示X和Y是同类。 
第二种说法是"2 X Y",表示X吃Y。 
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 
1) 当前的话与前面的某些真的话冲突,就是假话; 
2) 当前的话中X或Y比N大,就是假话; 
3) 当前的话表示X吃X,就是假话。 
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 

Input

第一行是两个整数N和K,以一个空格分隔。 
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 
若D=1,则表示X和Y是同类。 
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

这个题是一个种类并查集,就是除了集合还有集团,两种关系,开始我一直搞不懂,然后就从网上找题解。最后从网上找到了一种向量的思维模式,帮助我搞懂了。

网址是https://blog.csdn.net/niushuai666/article/details/6981689

里面关系式我一开始不懂,但是想了一想就懂了,rootx-rooty,他转化成了向量就成了,rootx->x+x->y+y->rooty,他自己定义的是f[x].relation的意思是父亲对儿子的关系,即0:父亲和儿子是同类,1:父亲被儿子吃,2:父亲吃儿子。那么就可以转化了,rootx->x==f[x].relation,x->y==type-1,y->rooty==-rooty-y==3-f[y].relation.把他们三个加起来就是y归并倒x里面后y与x的关系。

大神就是厉害 - -。向量思维模式,吊。

下面是我写的代码,跟他的差不多 - -。

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <cmath>
#include <list>
#include <deque>
#include <queue>
#include <stack>
using namespace std;
struct node{
	int parent;
	int relation;
};
node f[60000];
int n,k,sum=0;
void init()
{
    for(int i=1;i<=n;i++)
    {
        f[i].parent=i;
        f[i].relation=0;
    }
}
int getf(int v)
{
    if(f[v].parent==v)
    {
        return v;
    }
    int temp=f[v].parent;
    f[v].parent=getf(temp);
    f[v].relation=(f[v].relation+f[temp].relation)%3;
    return f[v].parent;
}
int main()
{ 	scanf("%d %d",&n,&k);
    init();
	while(k--)
	{
		int type,a,b;
		scanf("%d %d %d",&type,&a,&b);

		if(a>n || b>n)
		{sum++;
		continue;
		}
		if(type==2 && a==b)
		{
			sum++;
			continue;
		}
		int x=getf(a),y=getf(b);
		if(x!=y)
		{
            f[y].parent=x;
            f[y].relation=(f[a].relation+type-1+3-f[b].relation)%3;
		}
		else
        {
            if(type==1 && f[a].relation!=f[b].relation)
            {
                sum++;
                continue;
            }
            if(type==2  && type-1!=(3-f[a].relation+f[b].relation)%3)
            {
                sum++;
                continue;
            }
        }
	}
	printf("%d",sum);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值