Passing the Message

What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come out at last. With the result, she can evaluate the communication skills of those kids. 
Because all kids have different height, Teacher Liu set some message passing rules as below: 

1.She tells the message to the tallest kid. 

2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”. 

3.A kid’s “left messenger” is the kid’s tallest “left follower”. 

4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”. 

5.When a kid looks left, he can only see as far as the nearest kid who is taller than him. 

The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”. 

For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid. 
Your task is just to figure out the message passing route.

Input

The first line contains an integer T indicating the number of test cases, and then T test cases follows. 
Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than 2^31 – 1 .

Output

For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no “left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)

Sample Input

2
5
5 2 4 3 1
5
2 1 4 3 5

Sample Output

Case 1:
0 3
0 0
2 4
0 5
0 0
Case 2:
0 2
0 0
1 4
0 0
3 0

这个题一看就是单调栈,但是我却不知从何下手,题目给的意思是,先找最高点,然后再找左信使(即左边比他矮的最高的),然后再找又信使,最后经过同学的点化,我终于明白的,就是两个单调栈,一个从左往右的递减的单调栈,用来找右信使,然后一个从右往左的单调栈,用来找左信使。定义两个专门存左右信使的数组来存储他们,然后分两列输出就行了。详细的我在代码里解释一下。代码写得也有点乱,左右名字定义反了 - - 当时测试太慌了- -。哎。

(最后说一下,这个题 一次就A了 ,YES!!)

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <cmath>
#include <list>
#include <queue>
#include <stack>
using namespace std;
typedef long long ll;
int lmin[50001],rmin[50001],rne[50001],lne[50001];  
ll a[50001];
int n,t=1;
int main()
{	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		stack<ll> S;
		for(int i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);	
		}
    for(ll j=1;j<=n;j++)
    {
        while(!S.empty() && a[j]>=a[S.top()] ) S.pop();
        if(S.empty()) lmin[j]=0;
        else{
            lmin[j]=S.top();
            lne[S.top()]=j;  //以他为头节点的话,那么J最后一定是比他小的最大的! 
        }
        S.push(j);
    }
    
    
    
    while(!S.empty()) S.pop();
	
	
	
	
	for(ll j=n;j>=1;j--)
    {
        while(!S.empty() && a[j]>=a[S.top()]) S.pop();
        if(S.empty()) rmin[j]=n+1;
        else{
            rmin[j]=S.top();
            rne[S.top()]=j;
        }
        S.push(j);
    }
    int max=a[1],maxi=1;
    for(int i=1;i<=n;i++)
    {if(lmin[i]==0)
    {max=a[i];
    maxi=i;
	}
	}
	printf("Case %d:\n",t);
	t++;
	for(int i=1;i<=n;i++)
	{
		printf("%d %d\n",rne[i],lne[i]);  // rne和lne名字定义反了- -
	}
	
	memset(lmin,0,sizeof(lmin));
	memset(rmin,0,sizeof(rmin));
	memset(rne,0,sizeof(rmin));
	memset(lne,0,sizeof(lne));
	memset(a,0,sizeof(a));
	}
	
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值