1031 Hello World for U (20分)

题目

Given any string of N ( ≥ 5 ) N(\ge5) N(5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 n_1 n1 characters, then left to right along the bottom line with n 2 n_2 n2 characters, and finally bottom-up along the vertical line with n 3 n_3 n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n 1 = n 3 = m a x { k ∣ k ≤ n 2 f o r a l l 3 ≤ n 2 ≤ N } n_1 = n_3 = max\{k | k\le n_2 forall 3\le n_2 \le N\} n1=n3=max{kkn2forall3n2N} with n 1 + n 2 + n 3 − 2 = N n_1+n_2+n_3-2=N n1+n2+n32=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意

给出一个字符串,这个字符串长度在5~80之间,要求把这个字符串按U的形状输出,即两列竖一列横,竖着的用 n 1 n_1 n1 n 2 n_2 n2表示,且 n 1 = n 2 n_1=n_2 n1=n2,横着的用 n 3 n_3 n3表示,三者满足关系, n 1 + n 2 + n 3 − 2 = N n_1+n_2+n_3-2=N n1+n2+n32=N

解题思路

个人认为这只是一道找规律的题目,显然这个题的关键是求出 n 2 n_2 n2,可以试着模拟几个例子,不难发现规律, n 2 n_2 n2是等于n/3.0向上取整,知道了这个问题就迎刃而解了,直接建立一个二维数组,将字符依次填充成U字形就可以了。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main(){
    int n;
    int n1, n2, n3;
    char str[81], ch[30][30];
    scanf("%s", str);
    n = strlen(str);
    n1 = n3 = int(ceil(n/3.0));
    n2 = n + 2 - n1 - n3;
    int k = 0;
    memset(ch, ' ', 30*30*sizeof(char));
    for(int i=0; i<n1; i++,k++){
        ch[i][0] = str[k];
    }
    for(int i=1; i<n2-1; i++,k++){
        ch[n1-1][i] = str[k];
    }
    for(int i=n3-1; i>=0; i--,k++){
        ch[i][n2-1] = str[k];
    }
    for(int i=0; i<n1; i++){
        for(int j=0; j<n2; j++)
            printf("%c", ch[i][j]);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值