题目
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.
First the playing order is randomly decided for N p N_p Np programmers. Then every N G N_G NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N G N_G NG winners are then grouped in the next match until a final winner is determined.
For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N P N_P NP and N G ( ≤ 1000 ) N_G(\le1000) NG(≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N G N_G NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains $N_P distinct non-negative numbers W i ( i = 0 , ⋯ , N P − 1 ) W_i(i=0,\cdots,N_P-1) Wi(i=0,⋯,NP−1) where each W i W_i Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0 , ⋯ , N P − 1 0,\cdots,N_P-1 0,⋯,NP−1 (assume that the programmers are numbered from 0 to N P − 1 N_P-1 NP−1). All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the final ranks in a line. The i
-th number is the rank of the i
-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
题目大意
给你 N P N_P NP个老鼠以及他们的重量W,每 N G N_G NG 个老鼠分一个组,不够 N G N_G NG个数的单独算一个组,比他们每个组的最大值,最大值进入下一轮的比较,同组其余老鼠皆为淘汰,并与其他组同时被淘汰的老鼠排名一致,求所有老鼠的排名。
代码
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int main(){
int np[1000], ng[1000], ans[1000], p, g;
queue<int> que;
scanf("%d%d", &p, &g);
for(int i=0; i<p; i++)
scanf("%d", np+i);
for(int t, i=0; i<p; i++){
scanf("%d", &t);
ng[i] = t;
que.push(t);
}
fill(ans, ans+p, 0);
int c = 0;
while(que.size() > 1){
c++;
int t = que.size(), i = -1, maxs = -1, cnt = 0;
while(t--){
int temp = que.front();
que.pop();
cnt++;
if(np[temp] > maxs){
if(i != -1)
ans[i] = c;
i = temp;
maxs = np[temp];
}
else{
ans[temp] = c;
}
if(cnt == g){
que.push(i);
i = -1;
maxs = -1;
cnt = 0;
}
}
if(cnt < g && i != -1){
que.push(i);
}
}
ans[que.front()] = ++c;
int t = 1, temp = c;
while(c){
int cnt = 0;
for(int i=0; i<p; i++){
if(ans[i] == c){
cnt++;
ans[i] = t + temp;
}
}
t += cnt;
c--;
}
for(int i=0; i<p; i++){
if(i)
printf(" ");
printf("%d", ans[i]-temp);
}
return 0;
}