1058 A+B in Hogwarts (20分)

题目

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A + B A+B A+B where A A A and B B B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [ 0 , 1 0 7 ] [0,10^7] [0,107], Sickle is an integer in [ 0 , 17 ) [0, 17) [0,17), and Knut is an integer in [ 0 , 29 ) [0, 29) [0,29)).

Input Specification:

Each input file contains one test case which occupies a line with A A A and B B B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A A A and B B B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

代码

#include <iostream>
#include <cstdio>
using namespace std;

int main(){
    int a, b, c;
    int t1, t2, t3;
    scanf("%d.%d.%d %d.%d.%d", &a, &b, &c, &t1, &t2, &t3);
    int flag = 0;
    c += t3;
    flag = c/29;
    c %= 29;
    b += flag + t2;
    flag = b/17;
    b %= 17;
    a += t1 + flag;
    printf("%d.%d.%d\n", a, b, c);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值