1080 Graduate Admission (30分)

题目

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G E G_E GE, and the interview grade G I G_I GI. The final grade of an applicant is ( G E + G I ) / 2 (G_E+G_I)/2 (GE+GI)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G E G_E GE. If still tied, their ranks must be the same.

Each applicant may have K K K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N ( ≤ 40 , 000 ) N(\le40,000) N(40,000), the total number of applicants; M ( ≤ 100 ) M(\le100) M(100), the total number of graduate schools; and K ( ≤ 5 ) K(\le5) K(5), the number of choices an applicant may have.

In the next line, separated by a space, there are M M M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N N N lines follow, each contains 2 + K 2+K 2+K integers separated by a space. The first 2 integers are the applicant’s G ​ E G_​E GE and G I G_I GI, respectively. The next K K K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M − 1 M-1 M1, and the applicants are numbered from 0 to N − 1 N-1 N1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

题目大意

模拟考生志愿录取,规则如下:

  1. 根据考生初试和复试总分按高到低排序,并给与名次;
  2. 若总分相同,则按初试分从高到低排序;若初试分也相同,则考生名次并列;
  3. 每个考生可以选择多个志愿,按考生名次以及考生志愿依次予以录取,即若某个学校名额满了,则考虑考生的下一个志愿;
  4. 对于名次并列的考生,学校必须予以录取(尽管名额已经满了);

思路

模拟排序的问题,关键在于读懂题目意思吧,题目意思弄明白后是一道很简单的题目。

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

struct App{
    int id, rank;
    int ge, gi;
    int choice[5];
};

bool cmp1(App a, App b){
    if(a.ge+a.gi != b.ge+b.gi)
        return a.ge+a.gi > b.ge+b.gi;
    else if(a.ge != b.ge)
        return a.ge > b.ge;
    else
        return false;
}

bool cmp2(App a, App b){
    return a.id < b.id;
}

int main(){
    App app[40000];
    int sch[100];
    int n, m, k;
    vector<vector<App> > ans(100);
    scanf("%d%d%d", &n, &m, &k);
    for(int i=0; i<m; i++)
        scanf("%d", &sch[i]);
    for(int i=0; i<n; i++){
        app[i].id = i;
        scanf("%d%d", &app[i].ge, &app[i].gi);
        for(int j=0; j<k; j++)
            scanf("%d", &app[i].choice[j]);
    }
    sort(app, app+n, cmp1);
    int r = 0, ge = 101, gi = 101;
    for(int i=0; i<n; i++){
        if(app[i].ge+app[i].gi < ge+gi){
            r++;
            app[i].rank = r;
            ge = app[i].ge, gi = app[i].gi;
        }
        else if(app[i].ge+app[i].gi==ge+gi&&app[i].ge<ge){
            r++;
            app[i].rank = r;
            ge = app[i].ge, gi = app[i].gi;
        }
        else{
            app[i].rank = r;
        }
    }
    for(int i=0; i<n; i++){
        for(int j=0; j<k; j++){
            int t = app[i].choice[j];
            if(ans[t].empty()&&sch[t]>0){
                ans[t].push_back(app[i]);
                sch[t]--;
                break;
            }
            else if(sch[t]>0 || ans[t].back().rank==app[i].rank){
                ans[t].push_back(app[i]);
                sch[t]--;
                break;
            }
        }
    }
    for(int i=0; i<m; i++){
        sort(ans[i].begin(), ans[i].end(), cmp2);
        for(int j=0; j<ans[i].size(); j++){
            if(j)
                printf(" ");
            printf("%d", ans[i][j].id);
        }
        printf("\n");
    }
    return 0;
}
逻辑斯蒂回归(Logistic Regression)是一种用于二类问题的统计模型,它假设因变量的概率布服从伯努利布,通过最大似然估计法学习模型参数。在这个案例中,我们可以使用逻辑斯蒂回归来预测Kaggle上"Graduate Admission" 数据集中学生是否会被录取。 首先,让我们了解一下数据集`Admission_Predict.csv`的属性: - `GRE Score`: 研究生入学考试成绩(范围从200到800) - `TOEFL Score`: 国际英语测试系统数(范围从0到120) - `University Rating`: 学校排名(1表示最高) - `SOP`: 推荐信的质量评(0-5) - `LOR`: 推荐信的数量评(0-5) - `CGPA`: 学术成绩加权平均(范围从0到4) - `Research`: 是否有研究经验(0表示无,1表示有) - `Chance of Admit:` 预测的目标变量,表示录取概率,范围在0到1之间 数据预处理步骤通常包括: 1. **加载数据**:使用pandas库读取CSV文件。 2. **检查缺失值**:如果存在缺失值,可以选择填充、删除或使用适当的策略(如均值、中位数)。 3. **数据类型转换**:将非数值特征(如类别特征)编码为数值类型,例如使用One-Hot编码。 4. **标准化或归一化**:对于连续数值特征,如`GRE Score`和`TOEFL Score`,可以使用Z-score标准化或最小-最大缩放。 5. **划数据集**:随机划为训练集和测试集(比如70%训练,30%测试)。 预测算法实现过程(Python示例,使用sklearn库): ```python import pandas as pd import numpy as np from sklearn.model_selection import train_test_split from sklearn.preprocessing import StandardScaler from sklearn.linear_model import LogisticRegression from sklearn.metrics import accuracy_score, confusion_matrix # 1. 加载数据 data = pd.read_csv('Admission_Predict.csv') # 2. 预处理数据 # 检查缺失值并处理 data.isnull().sum() # 将类别特征编码,假设'SOP', 'LOR', 'Research'是类别特征 categorical_features = ['SOP', 'LOR', 'Research'] data = pd.get_dummies(data, columns=categorical_features) # 选择数值特征 numeric_features = data.columns.difference(categorical_features) scaler = StandardScaler() data[numeric_features] = scaler.fit_transform(data[numeric_features]) # 3. 划数据集 X = data.drop('Chance of Admit:', axis=1) # 特征 y = data['Chance of Admit:'] # 目标 X_train, X_test, y_train, y_test = train_test_split(X, y, test_size=0.3, random_state=42) # 4. 创建和拟合模型 model = LogisticRegression() model.fit(X_train, y_train) # 5. 预测 y_pred = model.predict(X_test) # 6. 评估模型性能 accuracy = accuracy_score(y_test, y_pred) conf_mat = confusion_matrix(y_test, y_pred) print("Accuracy:", accuracy) ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值