hdu 1003 Max Sum

Max Sum

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6


问题连接:http://acm.hdu.edu.cn/showproblem.php?pid=1003

问题分析:

  • 简单的dp动态规划问题,求最大子序列的和
  • 用一个dp数组即可,判断前n个数的和是否大于0
  • if ( dp [i-1] >= 0 )   dp[i] = dp[i-1] +dp[i]    是,就加上前n个数的和。
  • else if( dp[i-1] < 0)  dp[i] = dp[i]  不是,就不加。

源代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int dp[100010];
int main()
{
    int t, ca = 0;
    scanf("%d", &t);
    int m = t;
    while(t--)
    {
        ca++;
        int n;
        scanf("%d", &n);
        memset(dp, 0 , sizeof(dp));
        for(int i = 1; i <= n; i++)
            scanf("%d", &dp[i]);
        int first = 1, last = 1, sum, t = 1;
        sum = dp[1];
        for(int i = 2; i <= n; i++)
        {
            if(dp[i-1] >= 0)        //如果前i项的和为负数
                dp[i] = dp[i-1]+dp[i];    
            else
                t = i;                //则抛弃dp【i-1】,起始位置为i
            if(dp[i] >= sum)
            {                //如果当前n项和大于sum
                sum = dp[i];
                first = t;    
                last = i;        
            }

        }
        printf("Case %d:\n", ca);
        printf("%d %d %d\n", sum, first, last);
        if(ca != m)               //注意格式
            printf("\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值