1.定义
从栈底元素到栈顶元素呈单调递增或单调递减,栈内序列满足单调性的栈;
2.实例
Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Consider this example:
= = = = - = Cows facing right --> = = = = - = = = = = = = = = 1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c1 through cN.
Sample Input
6 10 3 7 4 12 2
Sample Output
5
题意:一群高度不完全相同的牛从左到右站成一排,每头牛只能看见它右边的比它矮的牛的发型,若遇到一头高度大于或等于它的牛,则无法继续看到这头牛和后面的其他牛的发型。
给出这些牛的高度,计算每头牛可以看到的牛的数量的和。
思路:计算每头牛可以看到牛的头数,可以等效于每头牛可以被看到的次数
从左到右依次读取当前牛的高度,从栈顶开始把高度小于或等于当前牛的高度的那些元素删除,此时栈中剩下的元素的数量就是可以看见当前牛的其他牛的数量,求和就是答案。
#include<iostream>
#include<algorithm>
#include<stack>
#include<cstdio>
using namespace std;
typedef long long ll;
int main(){
int n,m;
stack <int> s;
while(~scanf("%d",&n)){
ll sum=0;
cin>>m;
s.push(m);
for(int i=1;i<n;i++){
cin>>m;
while(!s.empty()&&m>=s.top()) s.pop();
sum+=s.size();
s.push(m);
}
cout<<sum<<endl;
}
return 0;
}