POJ 2456(二分)

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18719 Accepted: 8909

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source


        在这道题中可以先对给出的数据进行排序,排序完成之后通过二分找出那个满足农夫要求的最大值。(注意cin cout 会卡时间)

以下是代码

#include<map>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX_N=100000+50;
const int INF=0x3f3f3f3f;
int n,c;
int a[MAX_N];


//判断给出的二分值是否满足农夫的要求 
bool C(int x)
{
	int last = 0;
	for(int i = 1;i < c;i++)
	{
		int cnt = last+1;
		while(cnt < n && a[cnt]-a[last] < x)
		{
			cnt++;
		}
		if(cnt == n) return false;
		last = cnt;
	}
	return true;
}

int main()
{
	scanf("%d%d",&n,&c);
	for(int i = 0;i < n;i++)
	{
		scanf("%d",&a[i]);	
	}
	sort(a,a+n);
	int lt=0,rt=INF;
	while(rt - lt > 1)
	{
		int mid = (rt+lt)/2;
		if(C(mid))	lt = mid;
		else rt = mid;
	}
	printf("%d\n",lt);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

吃货智

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值