Aggressive cows
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 18719 | Accepted: 8909 |
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C
* Lines 2..N+1: Line i+1 contains an integer stall location, xi
* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3 1 2 8 4 9
Sample Output
3
Hint
OUTPUT DETAILS:
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.
Source
在这道题中可以先对给出的数据进行排序,排序完成之后通过二分找出那个满足农夫要求的最大值。(注意cin cout 会卡时间)
以下是代码
#include<map>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX_N=100000+50;
const int INF=0x3f3f3f3f;
int n,c;
int a[MAX_N];
//判断给出的二分值是否满足农夫的要求
bool C(int x)
{
int last = 0;
for(int i = 1;i < c;i++)
{
int cnt = last+1;
while(cnt < n && a[cnt]-a[last] < x)
{
cnt++;
}
if(cnt == n) return false;
last = cnt;
}
return true;
}
int main()
{
scanf("%d%d",&n,&c);
for(int i = 0;i < n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
int lt=0,rt=INF;
while(rt - lt > 1)
{
int mid = (rt+lt)/2;
if(C(mid)) lt = mid;
else rt = mid;
}
printf("%d\n",lt);
return 0;
}