英文单词排序

7-1 英文单词排序 (25 分)

本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。

输入格式:

输入为若干英文单词,每行一个,以#作为输入结束标志。其中英文单词总数不超过20个,英文单词为长度小于10的仅由小写英文字母组成的字符串。

输出格式:

输出为排序后的结果,每个单词后面都额外输出一个空格。

输入样例:

blue
red
yellow
green
purple
#

输出样例:

red blue green yellow purple 

c和c++都可以。这里c采用冒泡排序的方法,c++用sort就行。

c语言版:

# include<stdio.h>
# include<string.h>
int main()
{
	char s[100][10];
	int a[100]={0};
	char t[10];
	int i=0,j,z;
	while(1)
	{
		scanf("%s",s[i]);
		if(s[i][0]=='#')
			break;
		i++;
	}
	for(j=0;j<i-1;j++)
		for(z=0;z<i-j-1;z++)
			if(strlen(s[z])>strlen(s[z+1]))
			{
				strcpy(t,s[z]);
				strcpy(s[z],s[z+1]);
				strcpy(s[z+1],t);		
			}
	for(j=0;j<i;j++)
		printf("%s ",s[j]);
}

c++版:

#include<bits/stdc++.h>
using namespace std;
bool cmp(string a,string b)
{
	return a.size()<b.size();
}
int main()
{
	int j;
	string s[20];
	int i=0;
	while(1)
	{
		cin>>s[i];
		if(s[i]=="#")
			break;
		i++;
	}
	sort(s,s+i,cmp);
	for(j=0;j<i;j++)
		cout<<s[j]<<" ";
} 

 

  • 22
    点赞
  • 71
    收藏
    觉得还不错? 一键收藏
  • 6
    评论
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值