题目地址

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city
​1
​​ -city
​2
​​ and city
​1
​​ -city
​3
​​ . Then if city
​1
​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city
​2
​​ -city
​3
​​ .

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3

Sample Output:
1
0
0

#include <iostream>
#include <vector>
#include<algorithm>
#include <cmath>
#include<map>
#include<cstring>
#include<string>
#include<set>
using namespace std;
const int maxn=1010;
int n,m,k,query,fa[maxn];
vector<int>v[maxn];
int find(int x){
    int a=x;
    while(x!=fa[x]) x=fa[x];
    while(a!=fa[a]){
        int t=a;
        a=fa[a];
        fa[t]=x;                    //这里也是高频;
    }
    return x;               //一定一定不要忘了返回,超高频;
}
void union_it(int x,int y){
    int fx=find(x),fy=find(y);
    if(fx!=fy) fa[fx]=fy;
}
int main(){
    cin>>n>>m>>k;int v1,v2;
    
    for(int i=0;i<m;i++){
        cin>>v1>>v2;
        v[v1].push_back(v2);v[v2].push_back(v1);            //v1,v2高频写错;
    }
    while(k--){
        int query,cnt=0;bool ans[n+1]={0};
        for(int i=1;i<=n;i++) fa[i]=i;              //初始化拿下来;
        cin>>query;
        for(int i=1;i<=n;i++){
            if(i==query) continue;
            for(int j=0;j<v[i].size();j++){
                if(v[i][j]==query) continue;
                union_it(i,v[i][j]);
            }
        }
        for(int i=1;i<=n;i++) {
            if(i==query) continue;              //这里也要判断;
            if(!ans[find(i)])
            {
                ans[find(i)]=1;cnt++;
            }
        }
        cout<<cnt-1<<endl;
    }
}
// #include <iostream>
// #include <vector>
// #include<algorithm>
// #include <cmath>
// #include<map>
// #include<cstring>
// #include<string>
// #include<set>
// using namespace std;
// const int maxn=1010;int n,m,k,query;
// vector<int>v[maxn];map<int,bool> vis;
// void dfs(int idx){
//     if(idx==query||vis[idx]) return;
//     vis[idx]=1;
//     for(int i=0;i<v[idx].size();i++){
//         if(!vis[v[idx][i]])             //加个if就不超时了;
//         dfs(v[idx][i]);
//     }
// }
// int main(){
//     cin>>n>>m>>k;
//     int v1,v2;
//     for(int i=0;i<m;i++){
//         cin>>v1>>v2;
//         v[v1].push_back(v2);
//         v[v2].push_back(v1);
//     }
//     while(k--){
//         cin>>query;
//         int cnt=0;
// //        memset(vis,0,sizeof(vis));
//         vis.clear();
//         for(int i=1;i<=n;i++){
//             if(i==query||vis[i]) continue;
//             dfs(i);
//             cnt++;
//         }
//         cout<<cnt-1<<endl;
//     }
// }