题目地址

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2

Sample Output:
Yes
Yes
No

作者: CHEN, Yue
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB

#include <iostream>
#include <vector>
#include<algorithm>
#include <cmath>
#include<map>
#include<cstring>
#include<string>
#include<set>
using namespace std;
const int maxn=1010;
bool is_prime(int num){
    if(num<=1) return 0;            //tip 1;
    int sqr=sqrt(num*1.0);
    for(int i=2;i<=sqr;i++){        //tip 2;
        if(num%i==0) return 0;      
    }
    return 1;
}
int change(int n,int d){
    int a[maxn],len=0,res=0;
    while(n){
        a[len++]=n%d;
        n/=d;
    }
    for(int i=0;i<len;i++){
        res+=a[i]*pow(d,len-i-1);
    }
    return res;
}
int main(){
    int n,d;
    while(1){
        cin>>n;
        if(n<0) break;
        cin>>d;
        if(!is_prime(n)){
            cout<<"No"<<endl;continue;
        }
        int num=change(n,d);
        if(!is_prime(num)){
            cout<<"No"<<endl;continue;
        }
        cout<<"Yes"<<endl;
    }
}