题目地址

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:
3 4 2 6 5 1

#include <iostream>
#include <vector>
#include<algorithm>             //入栈顺序就是先序顺序;
#include <cmath>
#include<map>
#include<cstring>
#include<queue>
#include<string>
#include<set>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn=100010;
struct node{
    int data;
    node* lchild,*rchild;
};
int n,pre[maxn],in[maxn],cnt=0;string str;
stack<int>st;
node *create(int pre_l,int pre_r,int in_l,int in_r){
    if(pre_l>pre_r||in_l>in_r) return NULL;
    node* root=new node;
    root->data=pre[pre_l];
    int k=0;
    for(;k<n;k++){
        if(in[k]==pre[pre_l]) break;
    }
    int num_left=k-in_l;
    root->lchild=create(pre_l+1,pre_l+num_left,in_l,k-1);
    root->rchild=create(pre_l+num_left+1,pre_r,k+1,in_r);
    return root;
}
int temp=0;vector<int>ans;
void travel(node* root){
    if(!root) return;
    travel(root->lchild);
    travel(root->rchild);
    ans.push_back(root->data);
}
int main(){
    cin>>n;int cnt2=0;
    for(int i=0;i<2*n;i++){
        cin>>str;int num;
        if(str[1]=='u'){
            cin>>num;
            st.push(num);
            pre[cnt2++]=num;
        }
        else{
            in[cnt++]=st.top();
            st.pop();
        }
    }
    node *root=create(0,n-1,0,n-1);
//    cout<<root->data;
    travel(root);
    for(int i=0;i<ans.size();i++){
        if(i!=0) cout<<" ";
        cout<<ans[i];
    }
}