Floyd传递闭包 hrbust 1018

Cow Contest
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 347(144 users)Total Accepted: 160(130 users)Rating: Special Judge: No
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

For each test case:

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Process to the end of file.

Output

For each test case:

* Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
Hint

编号为2的奶牛输给了编号为1、3、4的奶牛,也就是说她的水平比这3头奶
牛都差。而编号为5的奶牛又输在了她的手下,也就是说,她的水平比编号为5的
奶牛强一些。于是,编号为2的奶牛的排名必然为第4,编号为5的奶牛的水平必
然最差。其他3头奶牛的排名仍无法确定。


题意:给出奶牛的关系,找出能确定排名的奶牛个数。


#include<stdio.h>
#include<string.h>
int main()
{
	int n,m;
	int map[105][105];
	while(~scanf("%d%d",&n,&m))
	{
		memset(map,0,sizeof map);
		for(int i = 0; i < m; i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			map[x][y] = 1;
		}
		for(int i = 1; i <= n; i++)
		for(int j = 1; j <= n; j++)
		for(int k = 1; k <= n; k++)
		if(map[j][i] == 1 && map[i][k] == 1)
			map[j][k] = 1; 
		int ans = 0;
		for(int i = 1; i <= n; i++)
		{
			int count=0;
			for(int j = 1; j <= n ; j++)
			{
				if(map[i][j] == 1)
					count++;
				if(map[j][i] == 1)
					count++;
			}
			if(count == (n-1))
				ans++;
		}
			
		printf("%d\n",ans);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值