【数位dp】 HDU - 3652 G - B-number

G - B-number  HDU - 3652 

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13
100
200
1000

Sample Output

1
1
2
2
问你在1-n中有几个数中有连续的13且可被13整除
重点在于被13整除,那么dp开三维
分别保存几位数,mod13的余数是几,当前状态,有没有出现过1,或者13

#include <bits/stdc++.h>
#define ll long long
using namespace std;

ll dp[20][20][5];  //dp[i][j][k] i位数%13为j的state为k的数有几个
int a[20];

ll dfs(int pos, int state, int mod, bool limit)
{
    if(pos == 0) return mod == 0 && state == 2; //如果到了最后,余数为0,状态又为2,就是有13,就return 1,否则return 0
    if(!limit && dp[pos][mod][state]!=-1) return dp[pos][mod][state]; 
    int up = limit ? a[pos] : 9; 
    ll ans = 0;
    for(int i = 0 ; i<=up ; i++)
    {
        int mod_x = (mod * 10 + i) % 13; //得到当前数的实际mod值
        int state_x;
        if(state == 2) state_x = 2;  //要是有了13,不用管了
        else if(i == 1) state_x = 1;  //不管前面有没有1,只要出现1,状态就为1
        else if(state == 1 && i == 3) state_x = 2; //有连续的13,状态就为2
        else state_x = 0; //否则,状态为0
        ans+=dfs(pos-1, state_x, mod_x, limit && i == a[pos]);
    }
    if(!limit) dp[pos][mod][state] = ans;
    return ans;
}

ll solve(ll x)
{
    int pos = 0;
    while(x)
    {
        a[++pos] = x%10;
        x/=10;
    }
    return dfs(pos, 0, 0, 1);
}
int main()
{
    ll n;
    memset(dp,-1,sizeof(dp));
    while(~scanf("%lld", &n))
    {
        printf("%lld\n", solve(n));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值