G - B-number HDU - 3652 (数位dp)

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13
100
200
1000

Sample Output

1
1
2
2
#include <stdio.h>
#include <algorithm>
#include<string.h>
using namespace std;
int a[20];
int dp[20][10][20][2];
int dfs(int pos,int pre,int kk,int stast ,bool limit)
{
    if(pos==-1)
    {
        if(stast&&kk==0) return 1;
        return 0;
    }
    if(!limit&&dp[pos][pre][kk][stast]!=-1) return dp[pos][pre][kk][stast];
    int up=limit?a[pos]:9;
    int tmp=0;
    for(int i=0;i<=up;i++)
    {
        if(pre==1&&i==3)
            tmp+=dfs(pos-1,i,(kk*10+i)%13,1,limit&&i==a[pos]);
        else
            tmp+=dfs(pos-1,i,(kk*10+i)%13,stast,limit&&i==a[pos]);
    }
    if(!limit) dp[pos][pre][kk][stast]=tmp;
    return tmp;
}
int slove(int x)
{
    int cnt=0;
    while(x)
    {
        a[cnt++]=x%10;
        x=x/10;
    }
    return dfs(cnt-1,0,0,0,true);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int n;
    while(~scanf("%d",&n))
        printf("%d\n",slove(n));
    
}

 

 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值