【Tarjan加边变为双联通图的边数】POJ - 3177 P - Redundant Paths

P - Redundant Paths POJ - 3177 

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. 

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample: 

One visualization of the paths is: 

   1   2   3
   +---+---+  
       |   |
       |   |
 6 +---+---+ 4
      / 5
     / 
    / 
 7 +

Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 

   1   2   3
   +---+---+  
   :   |   |
   :   |   |
 6 +---+---+ 4
      / 5  :
     /     :
    /      :
 7 + - - - - 

Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7 
Every pair of fields is, in fact, connected by two routes. 

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

求有桥连通图变为双连通图所需要最少的边的个数
求边双连通分支
1、tarjan找桥边
2、删除桥边(1、2两步同时完成)
3、剩余各部分则为双连通分量

有桥的连通图,加边变成双连通图
1、tarjan找桥边并删除桥边
2、将点双连通分量收缩成为一个顶点
3、加回桥边,统计度为1的顶点个数
4、根据规律,需要加入的桥边最少为(n+1)/2条

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=5005;
const int maxm=10005;
int head[maxm],to[maxm],nxt[maxm],e,index;
int low[maxn],dfn[maxn],inout[maxn],M[maxn][maxn],sum;

void init()
{
    e=index=sum=0;
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(inout,0,sizeof(inout));
    memset(M,0,sizeof(M));
}

void add(int u,int v)
{
    e++;
    to[e]=v;
    nxt[e]=head[u];
    head[u]=e;
}

void tarjan(int u,int father)
{
    low[u]=dfn[u]=++index;
    for(int i=head[u];i!=-1;i=nxt[i])
    {
        int v=to[i];
        if(!dfn[v])
        {
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
        }
        //如果引出v,而v是u的父亲,那么就不能更新low[u]
        else if(v!=father) low[u]=min(low[u],dfn[v]);
    }
}

int main()
{
    int n,m,a,b;
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            if(a==b) continue;
            if(M[min(a,b)][max(a,b)]) continue;
            M[min(a,b)][max(a,b)]=1;
            add(a,b);
            add(b,a);
        }
        tarjan(1,-1);
        for(int u=1;u<=n;u++)
        {
            for(int i=head[u];i!=-1;i=nxt[i])
            {
                int v=to[i];
                if(low[u]!=low[v]) inout[low[u]]++;//计算度数
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(inout[i]==1) sum++;//统计度为1的点的个数
        }
        printf("%d\n",(sum+1)/2);
    }
    return 0;
}




 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值