【二分答案+二分数据】POJ - 3579 E - Median

E - Median  POJ - 3579 

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

给你n个数,任取两个数,算出差的绝对值,一共有(n-1)*n/2个,从小到大排列后问你最中间的数是几

最开始跳不出n^2的思维怪圈,看了题解才知道你把这些数从小到大排列,那么只要第i个数和此数的差>=mid,后面的所有数和此数之差都满足,可以lower_bond出答案

那么复杂度为O(nlognlogn)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[100005];
int n,num;

bool ok(int x)
{
    int sum=0;
    for(int i=0;i<n;i++)
    {
        sum=sum+n-(lower_bound(a+i+1,a+n,a[i]+x)-a);
        //cout<<x<<" "<<sum<<endl;
    }
    if(sum>num) return 1;
    return 0;
}

int main()
{
    while(~scanf("%d",&n))
    {
        num=n*(n-1)/4;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int l=0,r=a[n-1]-a[0],ans=0;
        while(l<=r)
        {
            int mid=(l+r)/2;
            if(ok(mid))
            {
                l=mid+1;
                ans=mid;
            }
            else r=mid-1;
        }
        printf("%d\n",ans);
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值