【概率DP+矩阵快速幂】  POJ - 3744 Scout YYF I

Scout YYF I  POJ - 3744 

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with EOF
Each test case contains two lines. 
The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step. 
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000

有n个地雷,分别是1-100000000之间

你在位置1,每次走一步的概率是p,走两步的概率是1-p

问你每一个地雷都避过的概率是多少

每一次,如果该点是地雷就不能走,概率为0,那么每两个地雷中间有多少,就走多少正常的

如果遇见地雷了,就把那一步的概率变为0,记得到了最后要在走一步,因为要完美避开所有地雷,就是要走到最后一个地雷后一格

因为最多可能走1e8,不能线性推,但是dp[n]=dp[n-1]*p+dp[n-2]*(1-p),可以用矩阵快速幂

特别注意,你人的起始位置是1 

and   POJ输出请用f

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n,mine[15];
double p;

struct node
{
    double a[3][3];
};

node matrix(node x,node y)
{
    node r;
    memset(r.a,0,sizeof(r.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                r.a[i][j]+=x.a[i][k]*y.a[k][j];
            }
        }
    }
    return r;
}

double quickpow(int x,node r)
{
    node c;
    memset(c.a,0,sizeof(c.a));
    c.a[0][0]=p,c.a[0][1]=1,c.a[1][0]=1-p;
    while(x)
    {
        if(x%2) r=matrix(r,c);
        c=matrix(c,c);
        x/=2;
    }
    return r.a[0][0];
}

int main()
{
    while(~scanf("%d%lf",&n,&p))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&mine[i]);
        if(mine[1]==1)
        {
            printf("0.0000000\n");
            continue;
        }
        double q=0;
        mine[0]=1;
        node r;
        r.a[0][0]=1,r.a[0][1]=0;
        int t=0;
        for(int i=1;i<=n;i++)
        {
            if(i!=1)
            {
                r.a[0][0]=0,r.a[0][1]=q;
            }
            t=mine[i]-mine[i-1]-1;
            q=quickpow(t,r);
        }
        r.a[0][0]=0,r.a[0][1]=q;
        q=quickpow(1,r);
        printf("%.7f\n",q);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值