poj3744 概率DP+矩阵快速幂

Scout YYF I

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11139 Accepted: 3266

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1-p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with EOF.
Each test case contains two lines.
The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000

题意:在一条不满地雷的路上,你现在的起点在1处。在N个点处布有地雷,1<=N<=10。地雷点的坐标范围:[1,100000000].

每次前进p的概率前进一步,1-p的概率前进1-p步。问顺利通过这条路的概率。就是不要走到有地雷的地方。

 

设dp[i]表示到达i点的概率,则,初始值 dp[1]=1, dp[i]=p*dp[i-1]+(1-p)*dp[i-2];

但是由于坐标的范围很大,直接这样求是不行的.

N个有地雷的点的坐标为 x[1],x[2],x[3]```````x[N].

我们把道路分成N段:

1~x[1];

x[1]+1~x[2];

x[2]+1~x[3];

`

`

`

x[N-1]+1~x[N].

对于每一段,通过该段的概率等于1-踩到该段终点的地雷的概率。

就比如第一段 1~x[1].  通过该段其实就相当于是到达x[1]+1点。那么p[x[1]+1]=1-p[x[1]].

将每一段的概率累乘就是答案了。

每一段用矩阵加速就行了。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
double a[4][4];
double b[4][4];
double temp[4][4];
double res[4][4];
double p;
int m[15];
void muti(double a[][4],double b[][4])
{
    memset(temp,0,sizeof temp);
    for(int i=1; i<=2; i++)
        for(int j=1; j<=2; j++)
            for(int k=1; k<=2; k++)
                temp[i][j]+=a[i][k]*b[k][j];
    for(int i=1; i<=2; i++)
        for(int j=1; j<=2; j++)
            a[i][j]=temp[i][j];
}
void Pow(double a[][4],int n)
{
    memset(res,0,sizeof res);
    a[1][1]=p;
    a[1][2]=1-p;
    a[2][1]=1;
    a[2][2]=0;
    for(int i=1; i<=2; i++)
        res[i][i]=1;
    while(n>0)
    {
        if(n&1)
            muti(res,a);
        muti(a,a);
        n>>=1;
    }
}
int main()
{
    int n;
    while(scanf("%d%lf",&n,&p)!=EOF)
    {
        memset(m,0,sizeof m);
        for(int i=1; i<=n; i++)
            scanf("%d",&m[i]);
        sort(m+1,m+n+1);
        double ans=1.0;
        for(int i=1; i<=n; i++)
        {
            if(m[i]==m[i-1])
                continue;
            Pow(a,m[i]-m[i-1]-1);
            ans*=(1.0-res[1][1]);
        }
        printf("%.7f\n",ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值