【主席树模板题||划分树模板题】B - K-th Number POJ - 2104

B - K-th Number POJ - 2104

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

主席树

StatusAccepted
Time1766ms
Memory24944kB
Length1307
LangG++
Submitted2018-11-26 20:58:22
Shared 
RemoteRunId19521416
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
int T[maxn],L[maxn*20],R[maxn*20],sum[maxn*20];
int a[maxn],b[maxn];
int tot;

void build(int &rt,int l,int r)
{
    rt=++tot;
    sum[rt]=0;
    int mid=(l+r)/2;
    if(l==r) return ;
    build(L[rt],l,mid);
    build(R[rt],mid+1,r);
}

void update(int &rt,int l,int r,int pre,int x)
{
    rt=++tot;
    L[rt]=L[pre];
    R[rt]=R[pre];
    int mid=(l+r)/2;
    sum[rt]=sum[pre]+1;
    if(l==r) return ;
    if(x<=mid) update(L[rt],l,mid,L[pre],x);
    else update(R[rt],mid+1,r,R[pre],x);
}

int query(int l,int r,int s,int e,int k)
{
    if(l==r) return l;
    int mid=(l+r)/2;
    int res=sum[L[e]]-sum[L[s]];
    if(res>=k) query(l,mid,L[s],L[e],k);
    else query(mid+1,r,R[s],R[e],k-res);
}

int main()
{
    tot=0;
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        b[i]=a[i];
    }
    sort(b+1,b+n+1);
    int num=unique(b+1,b+n+1)-b-1;
    build(T[0],1,num);
    for(int i=1;i<=n;i++)
    {
        update(T[i],1,num,T[i-1],lower_bound(b+1,b+num+1,a[i])-b);
    }
    while(m--)
    {
        int ql,qr,k;
        scanf("%d%d%d",&ql,&qr,&k);
        int ans=query(1,num,T[ql-1],T[qr],k);
        printf("%d\n",b[ans]);
    }
    return 0;
}

 

划分树模板

StatusAccepted
Time1329ms
Memory14732kB
Length1768
LangG++
Submitted2018-11-26 18:02:37
Shared 
RemoteRunId19520646

 

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <iomanip>
#include <algorithm>
using namespace std;
const int maxn=100005;

struct node
{
    int num[maxn];
    int cnt[maxn];
}tree[20];
int a[maxn];

void build(int deep,int l,int r)
{
    if(l==r) return;
    int mid=(l+r)/2;
    int key=a[mid];
    int scnt=mid-l+1;
    for(int i=l;i<=r;i++)
    {
        if(tree[deep].num[i]<key) scnt--;
    }
    int left=l-1,right=mid,cnt=0;
    for(int i=l;i<=r;i++)
    {
        int num=tree[deep].num[i];
        if(num<key||(num==key&&scnt))
        {
            if(num==key) scnt--;
            ++cnt;
            tree[deep+1].num[++left]=num;
        }
        else tree[deep+1].num[++right]=num;
        tree[deep].cnt[i]=cnt;
    }
    build(deep+1,l,mid);
    build(deep+1,mid+1,r);
}

int query(int deep,int l,int r,int ql,int qr,int k)
{
    if(l==r) return tree[deep].num[l];
    int mid=(l+r)/2;
    int left=0,sum_left=tree[deep].cnt[qr];
    if(l!=ql)
    {
        left=tree[deep].cnt[ql-1];
        sum_left-=left;
    }
    if(sum_left>=k)
    {
        int newleft=left+l;
        int newright=newleft+sum_left-1;
        return query(deep+1,l,mid,newleft,newright,k);
    }
    else
    {
        int a=ql-left-l;
        int b=qr-ql-sum_left;
        int newleft=mid+1+a;
        int newright=newleft+b;
        return query(deep+1,mid+1,r,newleft,newright,k-sum_left);
    }
}


int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        tree[0].num[i]=a[i];
    }
    sort(a+1,a+n+1);
    build(0,1,n);
    while(m--)
    {
        int ql,qr,k;
        scanf("%d%d%d",&ql,&qr,&k);
        printf("%d\n",query(0,1,n,ql,qr,k));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ - 3616是一个目,目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值