The Euler function(Uva 2824)

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4757    Accepted Submission(s): 1990

Problem Description

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).

Output

Output the result of (a)+ (a+1)+....+ (b)

Sample Input

3 100

Sample Output

30 42

典型的欧拉函数应用,但是在这里还需要一点技巧,那就是打表,而且只用一个数组存,不然内存上和时间上可能过不去……

#include<bits/stdc++.h>
using namespace std;
#define N 3000000
long long phi[N];
void f()
{
    long long ans=0;
    memset(phi,0,sizeof(phi));
    for(int i=2;i<N;i++)
    {
        if(!phi[i])
        {
            for(int j=i;j<N;j+=i)
            {
                if(!phi[j])
                    phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
        ans+=phi[i];
        phi[i]=ans;
    }
}
int main()
{
    f();
    int a,b;
    while(scanf("%d%d",&a,&b)==2)
    {
        long long t=phi[b]-phi[a-1];
        printf("%lld\n",t);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值