Bone Collector(hdu 2602) (0-1背包模板)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 83595    Accepted Submission(s): 34602

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

14

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

0-1背包问题,顾名思义,只有两种状态0/1,不能用贪心法解决,而是用dp。

状态转移方程:dp[i][j]=max(dp[i][j],dp[i-1][j-v[i]]+w[i]);  dp[i][j]表示前i个物品恰放入一个容器为j的背包可以获得的最大价值。

PS:采用滚动数组降低空间复杂度。

当然,其实还有另外一种解法,DFS+记忆化搜索,特别是在数量较小,容量较大的时候适用.

#include<bits/stdc++.h>
using namespace std;
int w[1005],v[1005],dp[1005][1005];
int main()
{
    int n,c,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&c);
        for(int i=1;i<=n;i++) scanf("%d",&w[i]);
        for(int i=1;i<=n;i++) scanf("%d",&v[i]);
        for(int i=1; i<=n; i++)
            for(int j=0; j<=c; j++)
            {
                dp[i][j]=(i==1?0:dp[i-1][j]);
                if(j>=v[i]) dp[i][j]=max(dp[i][j],dp[i-1][j-v[i]]+w[i]);
            }
        printf("%d\n",dp[n][c]);

    }
}
//滚动数组
#include<bits/stdc++.h>
using namespace std;
int w[1005],v[1005],dp[1005];
int main()
{
    int n,c,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&c);
        for(int i=1;i<=n;i++) scanf("%d",&w[i]);
        for(int i=1;i<=n;i++) scanf("%d",&v[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=c; j>=0; j--)
            {
                if(j>=v[i]) dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
            }
        printf("%d\n",dp[c]);

    }
}
#include<bits/stdc++.h>
using namespace std;
int w[1005],v[1005],dp[1005][1005];
int dfs(int k,int c)  //记忆化搜索
{
    if(dp[k][c]>=0)
        return dp[k][c];
    if(k==0) return 0;
    int ans=dfs(k-1,c);
    if(c>=w[k])
        ans=max(ans,dfs(k-1,c-w[k])+v[k]);
    return dp[k][c]=ans;
}
int main()
{
    int n,c,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&c);
        for(int i=1;i<=n;i++) scanf("%d",&v[i]);
        for(int i=1;i<=n;i++) scanf("%d",&w[i]);
        memset(dp,0xff,sizeof(dp));
        printf("%d\n",dfs(n,c));
    }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值