Character Encoding(hdu 6397) (阶乘逆元+容斥原理)

Character Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 632    Accepted Submission(s): 240

Problem Description

In computer science, a character is a letter, a digit, a punctuation mark or some other similar symbol. Since computers can only process numbers, number codes are used to represent characters, which is known as character encoding. A character encoding system establishes a bijection between the elements of an alphabet of a certain size n and integers from 0 to n−1. Some well known character encoding systems include American Standard Code for Information Interchange (ASCII), which has an alphabet size 128, and the extended ASCII, which has an alphabet size 256.
For example, in ASCII encoding system, the word wdy is encoded as [119, 100, 121], while jsw is encoded as [106, 115, 119]. It can be noticed that both 119+100+121=340 and 106+115+119=340, thus the sum of the encoded numbers of the two words are equal. In fact, there are in all 903 such words of length 3 in an encoding system of alphabet size 128 (in this example, ASCII). The problem is as follows: given an encoding system of alphabet size n where each character is encoded as a number between 0 and n−1 inclusive, how many different words of length m are there, such that the sum of the encoded numbers of all characters is equal to k?
Since the answer may be large, you only need to output it modulo 998244353.

Input

The first line of input is a single integer T (1≤T≤400), the number of test cases.

Each test case includes a line of three integers n,m,k (1≤n,m≤105,0≤k≤105), denoting the size of the alphabet of the encoding system, the length of the word, and the required sum of the encoded numbers of all characters, respectively.

It is guaranteed that the sum of n, the sum of m and the sum of k don't exceed 5×106, respectively.

Output

For each test case, display the answer modulo 998244353 in a single line.

Sample Input

4

2 3 3

2 3 4

3 3 3

128 3 340

Sample Output

1

0

7

903

Source

2018 Multi-University Training Contest 8

x1+x2+....+xm=k,隔板法可知方案数为C(k+m-1,m-1).但是没考虑到取值范围,即xi可能超出了n,那么就要用到容斥原理.原来xi<=n-1,如果不满足的话,xi>=n,对于Xi=xi-n.如果有c个违反条件,X1+X2+...Xm=k-c*n,然后再运用容斥原理temp[i]=(-1)^c*C(m,c)*X(k-c*n+m-1,m-1).在在组合数的过程中,由于C(n,k)=n!/k!/(n-k)!一定可以整除,那么必然存在逆元,在取余的时候便可以用逆元求解.

#include <bits/stdc++.h>
using namespace std;
#define rep(i, n) for (int i = 0; i < (n); i++)
#define Rep(i, n) for (int i = 1; i <= (n); i++)
#define range(x) (x).begin(), (x).end()
typedef long long LL;
const LL mod = 998244353;
LL fact[200005], ifact[200005], inv[200005];
void init()
{
    fact[0] = 1;
    Rep (i, 200000) fact[i] = fact[i-1] * i % mod;
    /* 阶乘逆元 */
    inv[1] = 1;
    for (int i = 2; i <= 200000; i++)
        inv[i] = (mod - mod / i) * inv[mod % i] % mod;
    ifact[0] = 1;
    Rep (i, 200000) ifact[i] = ifact[i-1] * inv[i] % mod;
}
LL binom(LL m, LL n)//组合数C(m,n)
{
    return fact[m] * ifact[n] % mod * ifact[m-n] % mod;
}
LL subsolve(LL n, LL m)
{
    if (m < 0)
        return 0;
    return binom(m+n-1, n-1);
}
LL tmp[100005];

int main()
{
    init();
    int T;
    cin >> T;
    while (T--)
    {
        LL n, m, k;
        cin >> n >> m >> k;
        for (int i = 0; i <= m; i++)
            tmp[i] = binom(m, i) * subsolve(m, k-i*n) % mod;
        for (int i = m-1; i>=0; i--)//容斥原理
            tmp[i] = (tmp[i] + mod - tmp[i+1]) % mod;
        cout << tmp[0] << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值