hdu 1102 Constructing Roads(prim算法)

Constructing Roads

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26230    Accepted Submission(s): 10052

 

 

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

 

 

Sample Input

 

3

0 990 692

990 0 179

692 179 0

1

1 2

 

Sample Output

 

179

 

Source

kicc

 

【题解】

prim算法,从顶点着手构建最小生成树。

用vis[i]标记顶点i是否已放入最小生成树,用dis[i]存放顶点i与已存放入最小生成树的顶点相连的最短边的长度。

先将1放入最小生成树,然后开始寻找从1出发的最小边,总长度加上最小边长度,接着从最小边的另一个顶点出发继续寻找。

【代码】

 

#include<cstdio>
#include<cstring>
using namespace std;
const int inf=0x3f3f3f3f;
int map[105][105],vis[105],dis[105];
int n,ans;
void prim()
{
    int i,j,k;
    for(i=1;i<n;i++)
    {
        int min=inf;
        for(j=1;j<=n;j++)
            if(!vis[j]&&dis[j]<min)
            {
               k=j;
               min=dis[j];
            }
        ans+=min;
        vis[k]=1;
        for(j=1;j<=n;j++)
            if(!vis[j]&&dis[j]>map[k][j])
                dis[j]=map[k][j];
    }
}
int main()
{
    int m,i,j,a,b;
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                scanf("%d",&map[i][j]);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=0;
            map[b][a]=0;
        }
        for(i=1;i<=n;i++)
            dis[i]=map[i][1];
        vis[1]=1;
        ans=0;
        prim();
        printf("%d\n",ans);
    }
    return 0;
}

【共勉】

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值