畅通工程续 + Til the Cows Come Home(最短路)

【板子】

板子要理解,要熟练。

https://blog.csdn.net/qq_41117236/article/details/80517605

【一】

畅通工程续

TimeLimit:1000MS  MemoryLimit:32768KB

64-bit integer IO format:%I64d

Problem Description

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

SampleInput

3 3 
0 1 1 
0 2 3 
1 2 1 
0 2 
3 1 
0 1 1 
1 2

SampleOutput

2 
-1

【题解】

因为数据不大我就用了Floyd算法,简单又容易理解就是复杂度有点大,时间复杂度O(n^3)。

【代码】

#include<bits/stdc++.h>
using namespace std;
const int inf=0x3f3f3f3f;
int mp[205][205];
void floyd(int n)
{
    for(int k=0;k<n;k++)
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                mp[i][j]=min(mp[i][j],mp[i][k]+mp[k][j]);
}
int main()
{
    int n,m,a,b,x;
    while(~scanf("%d%d",&n,&m))
    {
        memset(mp,inf,sizeof(mp));
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&x);
            mp[a][b]=min(x,mp[a][b]);
            mp[b][a]=min(x,mp[b][a]);
        }
        floyd(n);
        scanf("%d%d",&a,&b);
        if(a==b) printf("0\n");
        else if(mp[a][b]<inf)
            printf("%d\n",mp[a][b]);
        else
            printf("-1\n");
    }
}

【二】

Til the Cows Come Home

TimeLimit:1000MS  MemoryLimit:65536K

64-bit integer IO format:%lld

Problem Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

SampleInput

5 5 
1 2 20 
2 3 30 
3 4 20 
4 5 20 
1 5 100

SampleOutput

90

【题解】

n最大为1000,O(n^3)显然不行,这里用Dijkstra算法,时间复杂度O(n^2)。

【代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1005
using namespace std;
const int inf=0x3f3f3f3f;
int dis[maxn],vis[maxn];
int mp[maxn][maxn];
int n;
void init()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            if(i==j)
                mp[i][j]=0;
            else
                mp[i][j]=inf;
        }
}
int djs(int st,int ed)
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=mp[st][i];
        vis[i]=0;
    }
    vis[st]=1;
    for(int i=1;i<n;i++)
    {
        int minn=inf;
        int next=-1;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0&&dis[j]<minn)
            {
                minn=dis[j];
                next=j;
            }
        }
        if(next==-1)  continue;
        vis[next]=1;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0)
                dis[j]=min(dis[j],dis[next]+mp[next][j]);
        }
    }
    return dis[ed];
}
int main()
{
    int t,a,b,x;
    while(~scanf("%d%d",&t,&n))
    {
        memset(mp,inf,sizeof(mp));
        while(t--)
        {
            scanf("%d%d%d",&a,&b,&x);
            mp[a][b]=min(x,mp[a][b]);
            mp[b][a]=min(x,mp[b][a]);
        }
        printf("%d\n",djs(1,n));
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值