Talented Chef

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most M different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).

<h4< style="background-color: transparent; border-bottom-left-radius: 0px; border-bottom-right-radius: 0px; border-top-left-radius: 0px; border-top-right-radius: 0px; box-shadow: none; font-family: &quot;Merriweather&quot;,serif; font-size: 18px; padding-bottom: 0px; padding-left: 0px; padding-right: 0px; padding-top: 0px;" dd=""> Output

For each test case, output the least time (in minute) to finish all dishes.

<h4< style="background-color: transparent; border-bottom-left-radius: 0px; border-bottom-right-radius: 0px; border-top-left-radius: 0px; border-top-right-radius: 0px; box-shadow: none; font-family: &quot;Merriweather&quot;,serif; font-size: 18px; padding-bottom: 0px; padding-left: 0px; padding-right: 0px; padding-top: 0px;" dd=""> Sample Input
2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10
<h4< style="background-color: transparent; border-bottom-left-radius: 0px; border-bottom-right-radius: 0px; border-top-left-radius: 0px; border-top-right-radius: 0px; box-shadow: none; font-family: &quot;Merriweather&quot;,serif; font-size: 18px; padding-bottom: 0px; padding-left: 0px; padding-right: 0px; padding-top: 0px;" dd=""> Sample Output
 
 
310
这道题是一道思路题,以前没做过,比赛时候想法有些局限,再加上题目意思理解的有些偏差,导致最后没有做出来,挺遗憾的,因此提醒大家以后做题千万理解好题意,很重要。
题目大意:多组输入,输出n个需要的盘子,m是一分钟内可以完成几个步骤,并且这几个步骤不相同,然后每个盘子需要几个步骤,输出做完所有步骤需要几分钟。
解析:暴力会超时的,题目限制是一秒,有一个快速方法,看代码就能看懂,是水题。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
using namespace std;
int main()
{
    int t,a,sum,n,m,maxn;
    scanf("%d",&t);
    while(t--)
    {
        maxn=sum=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            sum+=a;
            maxn=max(maxn,a);
        }
        if(maxn*m>=sum)
            printf("%d\n",maxn);
        else
            printf("%d\n",(sum-1)/m+1);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值