Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
 

2

题意:输入n,m,有n头奶牛,m个比赛,下面两个数是x,y,编号x奶牛和y奶牛对打,x奶牛赢了,按照谁厉害拍下顺序,看有几头奶牛的顺序是确定的。

解析:这道题由于奶牛数目只有100,所以可以用floyd这个算法,开一个二维数组a[i][j],如果 i 奶牛排在 j 奶牛前面,a[i][j]=1,反之是0,这样记录下所有奶牛之间的关系。
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[110][110];
int main()
{
    int n,m,x,y;
    scanf("%d%d",&n,&m);
    memset(a,0,sizeof(a));
    for(int i=0;i<m;i++)
    {
        scanf("%d%d",&x,&y);
        a[x][y]=1;
    }
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                a[i][j]=a[i][j]||(a[i][k]&&a[k][j]);
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        int j;
        for(j=1;j<=n;j++)
        {
            if(i==j) continue;
            if(a[i][j]==0&&a[j][i]==0) break;//只要判断i这头奶牛的前后就确定就说明i的顺序是确定的
        }
        if(j>n)
            ans++;
    }
    printf("%d\n",ans);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值