Power Network

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 


An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

 

解析:这道题就是普通的Dinic,只不过容易超时,必须用当前弧优化和炸点优化,否则就超时了

代码如下:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<string>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define mm 200
struct node
{
    int v,w,next;
} e[22222];
int vis[mm],next[mm];
int head,tail,tot;
void add_edge(int u,int v,int w)
{
    e[tot].v=v;
    e[tot].w=w;
    e[tot].next=next[u];
    next[u]=tot++;
    e[tot].v=u;
    e[tot].w=0;
    e[tot].next=next[v];
    next[v]=tot++;
}
int bfs()
{
    memset(vis,-1,sizeof(vis));
    vis[head]=0;
    queue<int>q;
    while(!q.empty())
        q.pop();
    q.push(head);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=next[u]; i!=-1; i=e[i].next)
        {
            int v=e[i].v;
            if(vis[v]==-1&&e[i].w>0)
            {
                vis[v]=vis[u]+1;
                q.push(v);
            }
        }
    }
    return vis[tail]!=-1;
}
int dfs(int u,int w1)
{
    if(u==tail)
        return w1;
    int f=0,g=0;
    for(int i=next[u]; i!=-1; i=e[i].next)
    {
        int v=e[i].v,w=e[i].w;
        if(vis[v]==vis[u]+1&&w>0&&(f=dfs(v,min(w1,w))))
        {
            e[i].w-=f;
            e[i^1].w+=f;
            return f;
            w1-=f;
            g+=f;
            if(!w1)
                break;
        }
    }
    vis[u]=-1;
    return g;
}

int Dinic()
{
    int ans=0;
    while(bfs())
    {
        ans+=dfs(head,inf);
    }
    return ans;
}
int main()
{
    int n,np,nc,m;
    int u,v,w;
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        tot=0;
        head=0,tail=n+2;
        memset(next,-1,sizeof(next));
        memset(e,0,sizeof(e));
        for(int i=1; i<=m; i++)
        {
            scanf(" (%d,%d)%d",&u,&v,&w);
            add_edge(u+1,v+1,w);
        }
        for(int i=1; i<=np; i++)
        {
            scanf(" (%d)%d",&u,&w);

            add_edge(head,u+1,w);
        }
        for(int i=1; i<=nc; i++)
        {
            scanf(" (%d)%d",&u,&w);
            add_edge(u+1,tail,w);
        }
        printf("%d\n",Dinic());
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值