PATA1003:Emergency的Dijkstra解法

题目描述

1003 Emergency (25分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers:
N (≤500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively.
The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city.
Then M lines follow, each describes a road with three integers c1 , c2 and L,
which are the pair of cities connected by a road and the length of that road, respectively.
It is guaranteed that there exists at least one path from C1 to C2 .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

思路分析

  1. 题目的要求是要求出两个城市之间最短路径的条数,以及保证路径最短的情况下可能请求的最大救援队伍。
  2. 这题可以用最短路径的算法来求解,用一个二维数组edge[i][j]来存储城市i与城市j之间的关系,记住在输入之前将该数组的初始化为一个大数(表示两者不连通),用一个数组dist[i]来表示从源到城市i的最短路径(这个数组也需要初始化为一个大数),用一个数组num[i]来表示从源到城市i的最短路径的条数,用一个数组cnt[i]来表示源到城市i的路径最短时的最大救援队伍数,用一个数组vis[i]来表示城市i是否已访问。
  3. 每次遍历都找到一个与源城市距离最近的城市u进行访问。对城市u进行访问的时候需要判断到从源到其他城市的最短路径、最短路径数目、且在路径最短情况下可能请求的饿最大救援队伍数进行更新。
  4. 分为dist[j]==dist[u]+edge[u][j]dist[j]>dist[u]+edge[u][j]两种情况

代码(AC代码)

#include<stdio.h>
#include<algorithm>
#define INF 1e9
using namespace std;
const int maxn=505;
int n,m,sr,en;
int edge[maxn][maxn];
int team[maxn]={0},num[maxn]={0},cnt[maxn]={0},dist[maxn],vis[maxn]={0};
//team存储城市的救援队伍数,num存储到达某城市的最短路径数,cnt存储到达某城市的最短路径数中能够获取的最大救援队伍数,dist存储能够到达结点i的最短距离数
//vis表示已遍历结点数 
void init()//读取数据 
{
	fill(dist,dist+maxn,INF);
	fill(edge[0],edge[0]+maxn*maxn,INF);//很关键的两个初始化 
	scanf("%d %d %d %d",&n,&m,&sr,&en);
	for(int i=0;i<n;i++)
		scanf("%d",&team[i]);
	
	for(int i=0;i<m;i++)
	{
		int v1,v2,weight;
		scanf("%d %d %d",&v1,&v2,&weight);
		edge[v1][v2]=weight;
		edge[v2][v1]=weight;
	}
	dist[sr]=0; 
	num[sr]=1;
	cnt[sr]=team[sr];	
} 
void Dijkstra()
{
	for(int i=0;i<n;i++)
	{
		int u=-1,min=INF;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==false&&dist[j]<min)
			{
				u=j;
				min=dist[j]; 
			}
		}
		vis[u]=1;
		for(int j=0;j<n;j++)
		{
			if(vis[j]==0&&edge[u][j]!=INF)
			{
				if(dist[u]+edge[u][j]<dist[j])
				{
					dist[j]=dist[u]+edge[u][j];
					num[j]=num[u];
					cnt[j]=cnt[u]+team[j];
				}
				else if(dist[u]+edge[u][j]==dist[j])
				{
					num[j]+=num[u];
					if(cnt[j]<cnt[u]+team[j])
						cnt[j]=cnt[u]+team[j];
				}
			}
		}
	}
}
int main()
{
	init(); 
	Dijkstra();
	printf("%d %d",num[en],cnt[en]);
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值