PAT A1052:Linked List Sorting之静态链表求解

题目描述

1052 Linked List Sorting (25分)
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10^5 ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [ − 1 0 5 , 1 0 5 ] [-10^5,10^5] [105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input,
where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

求解思路

  • 定义一个静态链表,添加一个bool型变量flag用于标志结点是否有效(1是0否),即结点是否出现在该链表上
  • 初始时,令所有结点的flag均为false
  • 从题目给出的链表首地址start开始遍历整条链表,并标记有效结点的flag为true,同时统计有效结点的个数count
  • 对结点进行排序,排序策略为:如果cmp的两个参数节点中有无效结点的话,则按flag从大到小排序,以把有效节点排到数组左端;否则的话按照数据从小到大排序
  • 按要求输出排序后的有效结点即可

代码实现(AC)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std; 
const int maxn=100010;
struct Node{
	int address,data,next;
	bool flag;
}node[maxn]; 
bool cmp(Node a,Node b)
{
	/*如果ab中存在一个无效结点,则将无效结点移到队尾,否则的话将节点值小的那个结点移到队首*/
	if(!a.flag||!b.flag)	return a.flag>b.flag;
	else	return a.data<b.data;
}
int n,start;
void init()
{
	for(int i=0;i<maxn;i++)
		node[i].flag=0;
	int address;
	scanf("%d %d",&n,&start);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&address);
		scanf("%d %d",&node[address].data,&node[address].next);
		node[address].address=address;
	}
}
void solve()
{
	int count=0,p=start;
	/*统计有效结点*/
	while(p!=-1)
	{
		node[p].flag=1;
		count++;
		p=node[p].next;
	}
	if(!count)	printf("0 -1\n");
	else
	{
		sort(node,node+maxn,cmp);
		printf("%d %05d\n",count,node[0].address);
		for(int i=0;i<count;i++)
		{
			if(i!=count-1)	printf("%05d %d %05d\n",node[i].address,node[i].data,node[i+1].address);
			else printf("%05d %d -1\n",node[i].address,node[i].data);
		}
	} 
}
int main()
{
	init();
	solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值