PAT A1051:Pop Sequence之栈模拟

题目描述

1051 Pop Sequence (25分)
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack.
For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

求解思路

给定m用于表示栈的最大容量,n为序列长度,k表示序列的个数。对于该栈,我们按照1、2、3、4、5、6、7的顺序压栈,然后判断待检验的一个序列,是否可以使得元素按照给出的顺序出栈。比如说1入栈,1出栈,2入栈,2出栈,……,7入栈,7出栈,即可以存在1,2,3,4,5,6,7的出栈顺序,故输出YES。
将待判断的序列放入到队列q中,从1-n开始遍历,每次将一个数i放入到栈s中,首先判断栈的大小是否超出了m,如果超出了则flag为false;之后判断如果栈和队列均非空且栈顶元素等于队首元素,那么则进行出栈、出队操作。在进行完n次入栈操作之后,判断如果栈非空,则flag为false。最终flag为false的时候输出NO,表示不满足这样的出栈顺序。否则为YES,表示存在这样的出栈顺序。

代码实现(AC)

#include<cstdio>
#include<stack>
#include<queue>
using namespace std;
void solve()
{
	int n,m,k;
	scanf("%d %d %d",&m,&n,&k);
	for(int i=0;i<k;i++)
	{
		bool flag=true;
		queue<int>q;
		stack<int>s;
		int temp;
		for(int j=0;j<n;j++)
		{
			scanf("%d",&temp);
			q.push(temp);
		}
		for(int j=1;j<=n;j++)
		{
			s.push(j);
			if(s.size()>m)	flag=false;
			while(!s.empty()&&!q.empty()&&s.top()==q.front())
			{
				s.pop();
				q.pop();
			}
		}
		if(!s.empty())	flag=false;
		if(flag)	printf("YES\n");
		else printf("NO\n");
	}
}
int main()
{
	solve();
	return 0;	
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值