PAT A1048:Find Coins

题目描述

1048 Find Coins (25分)
Eva loves to collect coins from all over the universe, including some other planets like Mars.
One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10^5 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10^5 , the total number of coins) and M (≤10^3 , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 +V2 =M and V1 ≤V2 . If such a solution is not unique, output the one with the smallest V1 . If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

求解思路

  1. 暴力搜索:对于某些测试案例会运行超时
  2. 首先对数据进行升序排列,i从0开始,j从n-1开始,只要i<j则一直进行迭代判断,如果判断两数相加等于M,则按要求输出这两个数,然后跳出循环。如果两数相加小于M,则令i++。如果两数相加大于M,则令j–。循环跳出之后,如果i>=j,则表示无解,按要求输出即可。

实现代码

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100001;
int n,m;
int num[maxn];
void solve()
{
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++)
		scanf("%d",&num[i]);
	sort(num,num+n);
	int i=0,j=n-1;
	while(i<j)
	{
		if(num[i]+num[j]==m)
		{
			printf("%d %d",num[i],num[j]);
			break;
		}
		else if(num[i]+num[j]<m)	i++;
		else j--;
	}
	if(i>=j)	printf("No Solution");
}
int main()
{
	solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值