PAT A1074:Reversing Linked List之静态链表排序

题目描述

1074 Reversing Linked List (25分)
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L.
For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

求解思路

  • 题意:给定一个静态链表,首地址begin1,结点数n,排序长度k。对于每一个节点,给定该节点的地址、数据以及该节点下一个节点的地址。
  • 定义一个结构体,其中包括节点的地址、数据、下一节点的地址以及当前节点在链表中的序号。
  • 首先按照节点id从小到大排序,所以初始化的时候需要让节点id均初始化为maxn,即让一些没有出现的节点放到筛掉。
  • 按照要求进行排序即可。

代码实现

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100001;
struct Node{
	int addr;
	int data;
	int next;
	int id;	//分别表示节点地址,数据,下一节点的地址,节点的id 
}node[maxn];
int begin1,n,k;
bool cmp1(Node a,Node b)
{
	return a.id<b.id;
	
}
bool cmp2(Node a,Node b)
{
	return a.id>b.id;
}
void solve()
{
	for(int i=0;i<maxn;i++)
		node[i].id=maxn;
	scanf("%d %d %d",&begin1,&n,&k);
	for(int i=0;i<n;i++)
	{
		int start;
		scanf("%d",&start);
		//node[start].id=i;
		node[start].addr=start;
		scanf("%d %d",&node[start].data,&node[start].next);
	}
	int index=0;
	while(begin1!=-1)
	{
		node[begin1].id=index++;
		begin1=node[begin1].next;
	}
	sort(node,node+maxn,cmp1);
	/*需要去除无效节点*/
	for(int i=0;i<index/k;i++)	//改成n会有一个测试样例通不过 
	{
		sort(node+i*k,node+(i+1)*k,cmp2);
	}
	for(int i=0;i<index;i++)
	{
		if(i!=index-1)
		{
			printf("%05d %d %05d\n",node[i].addr,node[i].data,node[i+1].addr);
		}
		else
		{
			printf("%05d %d -1\n",node[i].addr,node[i].data);
		}
	}
}
int main()
{
	solve();
	return 0;	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值