PAT A1115:Counting Nodes in a BST之搜索二叉树建树

题目描述

1115 Counting Nodes in a BST (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.The right subtree of a node contains only nodes with keys greater than the node’s key.Both the left and right subtrees must also be binary search trees.Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [?1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

求解思路

  • 题意:给定结点数目n,以及序列。要求我们建立一棵搜索二叉树,并且输出最底端的两层结点数目。
  • 按照要求建树即可。
  • 层次遍历的时候给结点赋予层号,统计每层的结点数以及最大的层数。

代码实现(AC)

#include<cstdio>
#include<queue>
using namespace std;
struct Node{
	int data;
	Node *lchild;
	Node *rchild;
	int level;
};
int n;
int levell[1010]={0},maxlevel=0;
Node* newNode(int value)
{
	Node* root=new Node;
	root->data=value;
	root->lchild=NULL;
	root->rchild=NULL;
	return root;
}
void insert(Node* &root,int value)
{
	if(root==NULL)
	{
		root=newNode(value);
		return;
	}
	else if(root->data>=value)
		insert(root->lchild,value);
	else if(root->data<value)
		insert(root->rchild,value);
	return; 
}
void levelTraversal(Node *root)
{
	queue<Node*>q;
	root->level=1;
	q.push(root);
	while(!q.empty())
	{
		Node* t=q.front();
		q.pop();
		levell[t->level]++;
		if(t->level>maxlevel)	maxlevel=t->level;
		if(t->lchild!=NULL)
		{
			t->lchild->level=t->level+1;
			q.push(t->lchild);
		}
		if(t->rchild!=NULL)
		{
			t->rchild->level=t->level+1;
			q.push(t->rchild);
		}
			
	}	
} 
void solve()
{
	scanf("%d",&n);
	Node *root=NULL;
	for(int i=0;i<n;i++)
	{
		int tmp;
		scanf("%d",&tmp);
		insert(root,tmp);
	}
	levelTraversal(root);
	printf("%d + %d = %d",levell[maxlevel],levell[maxlevel-1],levell[maxlevel]+levell[maxlevel-1]);
}
int main()
{
	solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
`std::counting_semaphore` 是 C++20 新增的同步原语之一,用于控制多个线程间的访问。它是一个计数信号量,可以用来限制同时访问某个资源的线程数量。在类的成员中使用 `std::counting_semaphore` 与在其他地方使用它并没有本质的区别,只需要在类的定义中声明一个 `std::counting_semaphore` 类型的成员即可。 以下是一个简单的示例代码: ```c++ #include <semaphore> #include <thread> #include <iostream> class Example { public: Example() : sema_(2) {} void do_something() { sema_.acquire(); std::cout << "Doing something..." << std::endl; std::this_thread::sleep_for(std::chrono::seconds(1)); sema_.release(); } private: std::counting_semaphore<2> sema_; }; int main() { Example e; std::thread t1(&Example::do_something, &e); std::thread t2(&Example::do_something, &e); std::thread t3(&Example::do_something, &e); t1.join(); t2.join(); t3.join(); return 0; } ``` 在这个例子中,`Example` 类中定义了一个 `std::counting_semaphore<2>` 类型的成员 `sema_`,用于控制同时访问 `do_something` 函数的线程数量。在 `do_something` 函数中,线程首先需要调用 `acquire()` 函数获取信号量,如果当前已经有两个线程在访问,则该线程会被阻塞,直到有一个线程调用了 `release()` 函数释放了信号量。在主函数中,我们创建了三个线程来同时访问 `do_something` 函数,由于信号量的数量是 2,因此最多只有两个线程能够同时访问,第三个线程需要等待前面的线程释放信号量后才能继续执行。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值