2883: 闰年判断

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 124   Solved: 68
[ Submit][ Status][ Web Board]

Description

定义一个函数leapyear,函数声明如下:


int leapyear(int n);   
//函数声明,如果参数n是闰年返回1,不是闰年返回0


在下面代码的基础上完成,提交时只提交leapyear的函数定义


#include <iostream>
using namespace std;
 
int leapyear(int n); //函数声明,如果参数n是闰年返回1,不是闰年返回0
 
int main()
{
   int year;
   cin>>year;  
   if( leapyear(year)==1 )
      cout<<"leapyear"<<endl;
   else
      cout<<"not leapyear"<<endl;   
   return 0;
}

Input

Output

如果输入的年是闰年输出leapyear,如果不是闰年输出not leapyear

Sample Input

2000

Sample Output

leapyear

HINT

提交时只提交leapyear的函数定义

Source

gyy



代码:



#include <iostream>
 using namespace std;
  
 int leapyear(int n); //函数声明,如果参数n是闰年返回1,不是闰年返回0
 
 int main()
 {
    int year;
    cin>>year;   
    if( leapyear(year)==1 )
       cout<<"leapyear"<<endl;
    else
       cout<<"not leapyear"<<endl;    
    return 0;
 }
  int leapyear(int n)
  {
  if((n%4==0&&n%100!=0)||(n%400==0))
  return 1;
  else return 0;
  }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值