There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.
The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.
When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:PBMC -> S1-> S3
. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3
, so that both stations will be in perfect conditions.
PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax(≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci(i=1,⋯,N) where each Ciis the current number of bikes at Si
respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1−>⋯−>Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.
Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.
Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
https://www.cnblogs.com/weedboy/p/7256552.html
1、使用迪杰斯特拉算法求出 PBMC到目的车站的最短距离。
2、使用dfs深度优先搜索找出所有满足最短路径的路线。
3、从所有最短路径中找到send和back最小的情况,使用sort排序来求解。
#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cstring>
using namespace std;
const int MAX=0x7fffffff;
int map[505][505];
int station[505];
bool visit[505];
int dis[505];
vector<vector<int> >res;
int mcap;
void init(int n)
{
res.clear();
for(int i=0;i<=n;i++)
{
station[i]=0;
visit[i]=false;
dis[i]=i==0?0:MAX;
for(int j=0;j<=n;j++)
{
map[i][j]=i==j?0:MAX;
}
}
}
void Dijkstra(int n)
{
int minst,minlong;
while(true)
{
minst=-1;
minlong=MAX;
for(int i=0;i<=n;i++)
{
if(!visit[i]&&dis[i]<minlong)
{
minlong=dis[i];
minst=i;
}
}
if(minst==-1) break;
visit[minst]=true;
for(int i=1;i<=n;i++)
{
if(!visit[i]&&map[i][minst]!=MAX&&minlong+map[i][minst]<dis[i])
dis[i]=minlong+map[i][minst];
}
}
}
void dfs(vector<int>& temp, int sum, int ending, int cur, int n)
{
if(sum>dis[ending]) return;
if(cur == ending && sum==dis[ending])
res.push_back(temp);
for(int i=1;i<=n;i++)
{
if(!visit[i]&&map[cur][i]!=MAX)
{
visit[i]=true;
temp.push_back(i);
dfs(temp,sum+map[cur][i],ending,i,n);
visit[i] = false;
temp.pop_back();
}
}
}
void count(vector<int>& a,int &send, int& back)
{
send=back=0;
int stanard=mcap/2;
for(int i=1;i<a.size();i++)
{
if(station[a[i]]>stanard)
back+=station[a[i]]-stanard;
else if(station[a[i]]<stanard)
{
if(stanard-station[a[i]]-back>=0)
{
send+=stanard-station[a[i]]-back;
back=0;
}
else
{
back-=stanard-station[a[i]];
}
}
}
}
static bool cmp(vector<int> a,vector<int> b)
{
int asend=0, bsend=0, aback=0, bback=0;
count(a,asend,aback);
count(b,bsend,bback);
if(asend!=bsend)
return asend<bsend;
else
return aback<bback;
}
int main()
{
int nums, ending, mroads;
cin>>mcap>>nums>>ending>>mroads;
// 每个站的容量 站的数量 需要调整的目标站点 路径数量
init(nums);
int temp;
for(int i=1;i<=nums;i++)
{
scanf("%d",&station[i]);
}
int s1,s2,t;
for(int i=0;i<mroads;i++)
{
cin>>s1>>s2>>t;
map[s1][s2] = t;
map[s2][s1] = t;
if(s1==0)
dis[s2]=t;
if(s2==0)
dis[s1]=t;
}
Dijkstra(nums); //首先使用迪杰斯特拉算法计算出最短路径
memset(visit,false,sizeof(visit));
vector<int> te(1,0);
dfs(te,0,ending,0,nums); //使用深度优先搜索,找出所有最短路径
sort(res.begin(),res.end(),cmp); //对所有的最短路径进行排序
int mysend=0,myback=0;
count(res[0],mysend,myback);
cout<<mysend<<" ";
for(int i=0;i<res[0].size();i++)
{
if(i==res[0].size()-1)
cout<<res[0][i]<<" ";
else
cout<<res[0][i]<<"->";
}
cout<<myback<<endl;
return 0;
}