HDU 1029 - Ignatius and the Princess IV

题目链接:HDU - 1029

                                       Ignatius and the Princess IV

                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
                                             Total Submission(s): 47420    Accepted Submission(s): 21084

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

 

Output

For each test case, you have to output only one line which contains the special number you have found.

 

Sample Input

5

1 3 2 3 3

11

1 1 1 1 1 5 5 5 5 5 5

7

1 1 1 1 1 1 1

 

Sample Output

3

5

1

题意解析:

题上吧啦吧啦的,不用一字一句看,总体意思就是我们需要找出出现次数超过(n+1)/ 2 的一个数字,然后进行输出就可以了

解题思路:

首先我们要开足够大的数组,把所有数全部存进去,然后再进行处理。

处理方法就是排序,对它们用 sort 排序,然后输出第(n+1)/ 2 个数就 OK 了。

代码篇:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[1000000];
int main()
{
    int n;
    while(cin >> n)
    {
        for(int i = 0; i < n; i++)
            scanf("%d",&a[i]);
        sort(a, a + n);
        cout << a[(n + 1) / 2] << endl;
    }
    return 0;
}

 

OVER!

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值