HDU - 1029 Ignatius and the Princess IV(DP?)

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 39043    Accepted Submission(s): 17042


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
 
 
51 3 2 3 3111 1 1 1 1 5 5 5 5 5 571 1 1 1 1 1 1
 

Sample Output
 
 
351
 

Code
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
    const int N = 999999;
    int i,n,a[N];
    while(~scanf("%d",&n))
    {
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        printf("%d\n",a[(n+1)/2]);
    }
    return 0;
}

反思:题目大意:给出N个数(N为奇数),至少出现过(N+1)/2次的数是特殊数,输出特殊数。做法有很多,这里选择将这组数进行排序,出现次数超过50%的数就在(N+1)/2的位置上,直接输出即可。其实这是一个“寻找多数问题”——主元素问题:已知数组,其中出现频率大于50%的数就是数组的主元素。这样的序列有一种性质:在原序列中去掉两个不同的数,在原序列中出现次数超过50%的数在新序列中出现次数也一定超过50%。当数组有序时,可以用中位数的方法解决。还有一种思路是使用减治法,等学会再补上做法。当时觉得题目很简单没有多想,直到看《啊哈算法》的时候才看到这个问题,其实还有很多种解法,自己的知识还是太少了,以后每道题都得认真思考思考~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值