简单博弈

Coin Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2417    Accepted Submission(s): 1317


Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.

The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.
 

Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10 9,1<=K<=10).
 

Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 

Sample Input
 
 
23 13 2
 
Sample Output
 
 
Case 1: firstCase 2: second
 

Author
NotOnlySuccess
 

Source
 

Recommend
lcy


简单的对称博弈问题,

只要第一个人没有一次全部拿走,后手者只要每次与其拿走对称位置上的硬币,致使把连续的硬币隔开,先手者就永远不会赢。

只需要对先手一次拿完和每次只能拿一个情况特判一下就好点击打开链接

AC代码:

#include <iostream>
#include<algorithm>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
    long long int n,i,j,k,a,b,x,y,z,m,p;
    while(scanf("%lld",&n)!=EOF)
    {
        for(i=0;i<n;i++)
        {

            scanf("%lld%lld",&a,&b);
            if(b==1)
            {
                if(a%2==0)
                 printf("Case %d: second\n",i+1);
                 else
                 printf("Case %d: first\n",i+1);
            }
            else
            {
            if(a<=b)

                printf("Case %d: first\n",i+1);

            else
            {
                printf("Case %d: second\n",i+1);
            }
            }

        }
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值