Build Tree

Home STD Contest Notification Clarification Problems Ranklist Status Statistics Print

Build Tree

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 776    Accepted Submission(s): 74

 

Problem Description

You need to construct a full n-ary tree(n叉树) with m layers.All the edges in this tree have a weight.But this weight cannot be chosen arbitrarily you can only choose from set S,the size of S is k,each element in the set can only be used once.Node 0 is the root of tree.

We use d(i) for the distance from root to node i.Our goal is to minimize the following expression:

min∑i=0Nd(i)




Please find the minimum value of this expression and output it.Because it may be a big number,you should output the answer modul p.

 

 

Input

The input file contains 2 lines.

The first line contains 4 integers,these respectively is k,m,n,p。(2 ≤ k ≤200000,2 ≤ p≤ 1015)

The second line contains k integers,represent the set S,the elements in the set guarantee less than or equal to 1015.

We guarantee that k is greater than or equal to the number of edges.

 

 

Output

The output file contains an integer.represent the answer.

 

 

Sample Input

 

5 2 3 10 1 2 3 4 5

 

 

Sample Output

 

6

 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll read() {
  ll x = 0;
  ll ch = getchar();
  while (ch < '0' || ch > '9') {
    ch = getchar();
  }
  while (ch >= '0' && ch <= '9') {
    x = x * 10 + (ll)(ch - '0');
    ch = getchar();
  }
  return x;
}
void out(ll a) {
  if (a < 0) {
    putchar('-');
    a = -a;
  }
  if (a >= 10) {
    out(a / 10);
  }
  putchar(a % 10 + '0');
}
ll a[200010], num[2000], sum[200010], tot[2000];
int main() {
  ll n, m, k;
  ll p;
  while(~scanf("%lld%lld%lld%lld", &k, &m, &n, &p)) {//n叉m层
    ll cnt = 0, t = 1, ans = 0;
    sum[0] = 0;
    for (ll i = 1; i <= k; i++) {
      a[i] = read();
    }
    num[1] = 0;
    tot[2] = 1;
    for (ll i = 2; i <= m; i++) {
      t *= n;
      cnt += t;
      num[i] = num[i-1] + t;//num[i] 第i层有num[i]条边 
      tot[i+1] = tot[i] + t;//倒 每层边需要使用多少次 
    }
    sort(a+1, a+k+1);
    for (ll i = 1; i <= cnt; i++) {
      sum[i] = (sum[i-1] + a[i]) % p;
    }
    for (ll i = 2; i <= m; i++) {
      ans = (ans + (((sum[num[i]] - sum[num[i-1]] + p) % p) * tot[m-i+2]) % p) % p;
    }
    out(ans);
    putchar('\n');
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值