DNA repair POJ - 3691 自动机+dp

一、内容

Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.

Input

The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.
The following N lines gives N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease.
The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by the
number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.

Sample Input

2
AAA
AAG
AAAG    
2
A
TG
TGAATG
4
A
G
C
T
AGT
0

Sample Output

Case 1: 1
Case 2: 4
Case 3: -1

二、思路

在这里插入图片描述

三、代码

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int N = 1005;
int n, tr[N][4], ne[N], f[N][N], cnt[N], len;
char s[N];
int getC(char c) {
	if (c == 'A') return 0;
	if (c == 'T') return 1;
	if (c == 'G') return 2;
	return 3;
}
void add() {
	int p = 0;
	for (int i = 0; s[i]; i++) {
		int j = getC(s[i]);
		if (!tr[p][j]) tr[p][j] = len++; 
		p = tr[p][j];
	} 
	cnt[p] = 1; //标记这个字符串 
}
void build() {
	queue<int> q;
	for (int i = 0; i < 4; i++) { //将第二层的节点入队 
		if (tr[0][i]) q.push(tr[0][i]);
	}
	while (!q.empty()) {
		int p = q.front(); q.pop();
		for (int j = 0; j < 4; j++) {
			int c = tr[p][j]; //子节点
			if (!c) tr[p][j] = tr[ne[p]][j];
			else {
				ne[c] = tr[ne[p]][j];
				cnt[c] |= cnt[ne[c]]; //把前面存在的字符串状态加上 
				q.push(c);
			}				
		}
	}
}
int main() {
	int T = 1;
	while (scanf("%d", &n), n) {
		memset(cnt, 0, sizeof(cnt));
		memset(ne, 0, sizeof(ne)); len = 1;
		memset(f, 0x3f, sizeof(f));
		memset(tr, 0, sizeof(tr));
		scanf("%d", &n);
		for (int i = 1; i <= n; i++) {
			scanf("%s", s); add();
		}
		build();
		scanf("%s", s + 1); n = strlen(s + 1);
		f[0][0] = 0;
		for (int i = 1; i <= n; i++) {
			int c = getC(s[i]);
			for (int j = 0; j <= len; j++) {
				for (int k = 0; k < 4; k++) {
					int t = (c != k); //代表需要修改的次数 若i字符与k不相同则为1 
					int tj = tr[j][k];
					//代表没有出现题目所给的串 
					if (!cnt[tj]) f[i][tj] = min(f[i][tj], f[i - 1][j] + t);  
				}
			}
		}
		int ans = 1e9;
		for (int j = 0; j <= len; j++) ans = min(ans, f[n][j]);
		printf("Case %d: %d\n", T++, ans == 1e9 ? -1 : ans);
	}	
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值