[Java] HDU-1563

一、内容

Find your present!

 In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others. 

Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5
1 1 3 2 2
3
1 2 1
0

Sample Output

3
2

二、思路

  1. 解法一:
    异或运算符是^。因为a^a=0,那么要找出单独的数(唯一一个出现一次的数),只需要将所有的数进行异或运算即可。
  2. 解法二:
    使用Map,map<String, Integer> 第一个保存数字,第二个保存次数,由于只会出现一次,遍历map若次数等于1输出即可。

三、代码

解法一:

import java.util.*;

public class HDU_1563 {
	static int n, a;
	static int ans;
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (true) {
			n = sc.nextInt();
			if (n == 0) return;
			ans = 0;
			for (int i = 0; i < n; i++) {
				a = sc.nextInt();
				ans ^= a;
			}
			System.out.println(ans);
		}
	}
}

解法二:

import java.util.*;

public class HDU_1563 {
	static int n;
	static HashMap<String, Integer> map = new HashMap<String, Integer>();
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (true) {
			n = sc.nextInt();
			if (n == 0) return;
			for (int i = 0; i < n; i++) {
				String str = sc.next();
				if (map.containsKey(str)) {
					map.put(str, map.get(str) + 1);
				} else {
					map.put(str, 1);
				}
			}
			for (String key : map.keySet()) { 
				if (map.get(key) == 1) {
					System.out.println(key);
					break;
				}
			}
			map.clear();
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值